Missing files in environment

conda doctor shows a lot of missing files, which seem to be dependencies (e.g. conda-libmamba-solver-23.11.1-pyhd8ed1ab_0). I haven’t run into any problems importing common packages. What am I supposed to do? Thanks.

Hi @rootsmusic! Can you paste the conda doctor report? Thanks!

Sorry @jaimergp, I tried conda doctor > conda.txt and received the error below. But I’m unsure whether the error is related to the missing packages.

>>>>>>>>>>>>>>>>>>>>>> ERROR REPORT <<<<<<<<<<<<<<<<<<<<<<

Traceback (most recent call last):
  File "C:\ProgramData\anaconda3\Lib\site-packages\conda\exception_handler.py", line 17, in __call__
    return func(*args, **kwargs)
  File "C:\ProgramData\anaconda3\Lib\site-packages\conda\cli\main.py", line 83, in main_subshell
    exit_code = do_call(args, parser)
  File "C:\ProgramData\anaconda3\Lib\site-packages\conda\cli\conda_argparse.py", line 140, in do_call
    result = plugin_subcommand.action(getattr(args, "_args", args))
  File "C:\ProgramData\anaconda3\Lib\site-packages\conda\plugins\subcommands\doctor\__init__.py", line 41, in execute
    display_health_checks(context.target_prefix, verbose=context.verbose)
  File "C:\ProgramData\anaconda3\Lib\site-packages\conda\plugins\subcommands\doctor\health_checks.py", line 130, in display_health_checks
    print(f"{OK_MARK} There are no packages with altered files.\n")
  File "C:\ProgramData\anaconda3\Lib\encodings\cp1252.py", line 19, in encode
    return codecs.charmap_encode(input,self.errors,encoding_table)[0]
UnicodeEncodeError: 'charmap' codec can't encode character '\u2705' in position 0: character maps to <undefined>

$ C:\ProgramData\anaconda3\Scripts\conda-script.py doctor

environment variables:
;C:\Windows\System32\OpenSSH;C:\Program Files\Microsoft VS Code\bin;C:
a\Local\Programs\Microsoft VS

 active environment : base
active env location : C:\ProgramData\anaconda3
        shell level : 2
   user config file : C:\Users\roots\.condarc

populated config files : C:\Users\roots.condarc
conda version : 23.10.0
conda-build version : 3.27.0
python version : 3.11.5.final.0
virtual packages : __archspec=1=x86_64
base environment : C:\ProgramData\anaconda3 (writable)
conda av data dir : C:\ProgramData\anaconda3\etc\conda
conda av metadata url : None
package cache : C:\ProgramData\anaconda3\pkgs
envs directories : C:\ProgramData\anaconda3\envs
platform : win-64
user-agent : conda/23.10.0 requests/2.31.0 CPython/3.11.5 Windows/10 Windows/10.0.22621 solver/libmamba conda-libmamba-solver/23.11.1 libmambapy/1.5.3
administrator : True
netrc file : None
offline mode : False

An unexpected error has occurred. Conda has prepared the above report.
If you suspect this error is being caused by a malfunctioning plugin,
consider using the --no-plugins option to turn off plugins.

Example: conda --no-plugins install

Alternatively, you can set the CONDA_NO_PLUGINS environment variable on
the command line to run the command without plugins enabled.

Example: CONDA_NO_PLUGINS=true conda install

@jaimergp, I manually copy-and-pasted the output from conda doctor below.

Environment Health Report for: C:\ProgramData\anaconda3

  1. Missing Files:

aiosignal-1.3.1-pyhd8ed1ab_0: 1

anaconda-cloud-auth-0.1.4-pyhd8ed1ab_0: 1

appdirs-1.4.4-pyh9f0ad1d_0: 1

archspec-0.2.2-pyhd8ed1ab_0: 8

asttokens-2.4.1-pyhd8ed1ab_0: 7

async-timeout-4.0.3-pyhd8ed1ab_0: 1

attrs-23.1.0-pyh71513ae_1: 6

backports-1.0-pyhd8ed1ab_3: 1

backports.functools_lru_cache-1.6.5-pyhd8ed1ab_0: 1

backports.tempfile-1.0-py_0: 2

backports.weakref-1.0.post1-pyhd8ed1ab_1003: 1

beautifulsoup4-4.12.2-pyha770c72_0: 27

boltons-23.0.0-pyhd8ed1ab_0: 26

certifi-2023.11.17-pyhd8ed1ab_0: 1

charset-normalizer-3.3.2-pyhd8ed1ab_0: 3

click-8.1.7-win_pyh7428d3b_0: 16

cloudpickle-3.0.0-pyhd8ed1ab_0: 3

clyent-1.2.2-pyhd8ed1ab_2: 7

colorama-0.4.6-pyhd8ed1ab_0: 7

conda-index-0.3.0-pyhd8ed1ab_1: 13

conda-libmamba-solver-23.11.1-pyhd8ed1ab_0: 1
dask-core-2023.11.0-pyhd8ed1ab_0: 251

defusedxml-0.7.1-pyhd8ed1ab_0: 8

entrypoints-0.4-pyhd8ed1ab_0: 1

exceptiongroup-1.2.0-pyhd8ed1ab_0: 6

executing-2.0.1-pyhd8ed1ab_0: 5

filelock-3.13.1-pyhd8ed1ab_0: 8

fsspec-2023.10.0-pyhca7485f_0: 48

future-0.18.3-pyhd8ed1ab_0: 196

idna-3.4-pyhd8ed1ab_0: 3

importlib_resources-6.1.1-pyhd8ed1ab_0: 27

ipython-8.17.2-pyh5737063_0: 274

jaraco.classes-3.3.0-pyhd8ed1ab_0: 2

jinja2-3.1.2-pyhd8ed1ab_1: 25

jsonpatch-1.33-pyhd8ed1ab_0: 1

jsonschema-4.20.0-pyhd8ed1ab_0: 30

jsonschema-specifications-2023.11.1-pyhd8ed1ab_0: 3

jupyter_client-8.6.0-pyhd8ed1ab_0: 38

locket-1.0.0-pyhd8ed1ab_0: 1

more-itertools-10.1.0-pyhd8ed1ab_0: 3

nbformat-5.9.2-pyhd8ed1ab_0: 40

packaging-23.2-pyhd8ed1ab_0: 11

partd-1.4.1-pyhd8ed1ab_0: 14

pkginfo-1.9.6-pyhd8ed1ab_0: 20

pkgutil-resolve-name-1.3.10-pyhd8ed1ab_1: 1

platformdirs-4.0.0-pyhd8ed1ab_0: 8

ply-3.11-py_1: 6

prompt-toolkit-3.0.41-pyha770c72_0: 144

pycparser-2.21-pyhd8ed1ab_0: 6

pygments-2.17.2-pyhd8ed1ab_0: 321

pyjwt-2.8.0-pyhd8ed1ab_0: 1

pysocks-1.7.1-pyh0701188_6: 1

python-dateutil-2.8.2-pyhd8ed1ab_0: 18

python-dotenv-1.0.0-pyhd8ed1ab_1: 8

python-fastjsonschema-2.19.0-pyhd8ed1ab_0: 10

pytz-2023.3.post1-pyhd8ed1ab_0: 6

qtpy-2.4.1-pyhd8ed1ab_0: 129

referencing-0.31.0-pyhd8ed1ab_0: 13

requests-2.31.0-pyhd8ed1ab_0: 1

requests-toolbelt-1.0.0-pyhd8ed1ab_0: 18

semver-3.0.2-pyhd8ed1ab_0: 1

soupsieve-2.5-pyhd8ed1ab_1: 7

tomli-2.0.1-pyhd8ed1ab_0: 4

toolz-0.12.0-pyhd8ed1ab_0: 29

tqdm-4.66.1-pyhd8ed1ab_0: 23

traitlets-5.13.0-pyhd8ed1ab_0: 24

truststore-0.8.0-pyhd8ed1ab_0: 6

urllib3-2.1.0-pyhd8ed1ab_0: 1

wcwidth-0.2.12-pyhd8ed1ab_0: 6

win_inet_pton-1.1.0-pyhd8ed1ab_6: 1

  1. Altered Files:

:white_check_mark: There are no packages with altered files.

  1. Environment listed in environments.txt file: :white_check_mark:

Thank you, @rootsmusic
Could you please run conda doctor --v and share the output here? Most of these packages have a single missing file. I would like to see if there is a pattern there.

@Mahe_Khan Due to Discourse’s character limit, I have to attach the output (in a .txt file that’s renamed .yml so Discourse would upload it). In my base environment, I’ve only installed packages related to notebook and I just updated conda.
missing.yml (143.2 KB)

It looks like all the missing files are .pyc files in __pycache__ directories. Not sure what’s going on but it shouldn’t affect anything since those are purely optional cache files.

1 Like

Yes @BrenBarn, you’re right. There are supposed to be missing files in “C:\ProgramData\anaconda3\Lib\site-packages\IPython” and “C:\ProgramData\anaconda3\Lib\site-packages\ipython-8.17.2.dist-info”. But neither folder actually has a __pycache__ directory!

Since I ran conda clean --all before conda doctor, I assume that the former command deleted the cache files. I don’t know why the latter command would also check cache files though.

This might be worth an issue in conda/conda. Thanks for the report!

Thanks, @BrenBarn
Yes, the missing .pyc files can be ignored.
The reason conda doctor is reporting those .pyc files is because it finds those listed in the conda-meta directory as being a part of the package (which is what conda doctor reads to generate these reports). I will be investigating further why it was decided to make note of those __pycache__ files in the conda-meta in the first place. From there we could have two possible solutions: either we skip listing __pycache__ files in the conda-meta or we add an additional check to conda doctor to ignore those files as they are creating a false positive.
Thanks for bringing this up! I have opened a ticket in conda/conda to track this bug.

1 Like